在 2017 年 3 月 28 日发布 Ruby 2.2.7 之后,Ruby 2.2
的支持进入了安全维护期。现已过去一年,该阶段已结束。Ruby 新版的 bug
和安全修复不再移植到 2.2 系列,也不再发布 2.2
系列的版本补丁。建议尽快升级至 Ruby 2.5 或 2.4 版本。

原文链接

Ruby 在6月份发布了
2.6 全新系列的第二个预览版本,该版本由于引入期待已久的新特性
JIT 而被认为对于 Ruby 有着不同寻常的意义。在此前的 Ruby 25
周年的庆祝会上,创始人 Matz 也曾透露,Ruby
下一步将主要围绕“提高生产力”的核心目标进行发展,Ruby 3
将主打快速、分布式(可伸缩)和精明(分析),澳门新葡亰游戏网址,最终实现 3
倍提速。Ruby
3 计划在 2020 年发布,而 Ruby 2.6 则是为推进其 3
倍提速目标实现而迈出的第一步。

Ruby 1.9.2 RC 发布了. 这是 Ruby 1.9.2的候选发布版本

澳门新葡亰游戏网址 1

Ruby 1.9.2 会尽可能兼容 1.9.1, 以下是不兼容的更新以及新特性:

Ruby 版本当前支持状态

许多新的方法新的 socket API
(支持IPv6)新的字符编码支持更多随机生成器的随机类重新实现的Time.不再有”2038年”的问题一些正则表达式的增强$:不再包含当前路径基于libffi重新实现dl新的libyaml包装库psych,取代syck.

Ruby 2.5 系列

目前处于常规维护阶段。必要时,会移植 bug
修复,发布新版。如果发现严重安全问题,会发布紧急修复。

可以访问 NEWS 与 ChangeLog 查看更多新特性以及更新细节

Ruby 2.4 系列

目前处于常规维护阶段。必要时,会移植 bug
修复,发布新版。如果发现严重安全问题,会发布紧急修复。

此次发布修复了1.9.2 preview 3 的大概130个bugs, 包含所有已知的主要bugs,
除了#3462.

网站地图xml地图